Does Golaem Crowd support my renderer / my renderer version?

The most up-to-date information about the supported renderers are the release notes

Note that if you are using the oldest version of a renderer for which two versions are supported (e.g. V-Ray 2.4 and V-Ray 3), you probably need to do one extra-step manually after installation.

If your renderer is not supported, drop us a line, you never know...