My animations looks fine, so why do they not blend nicely in the locomotion set ?

Each individual animation may looks nice, but once they're all in a Locomotion Set, they're going to be blended together depending on the linear and angular speeds of the character, so many things may hurt the animation's quality.

Are Animations working correctly ?

First thing first, make sure all the animations do work correctly when individually used in a Motion Behavior. Check that they are cyclic and that each motion and contain one and only one support phase / footprint per channel.

Did you follow the locomotion set creation guidelines ?

The Creating a Locomotion Set page explains how to create a working locomotion set.

Did you check if the motion footprints are correct?

The Setting Footprints on your Motions tutorial explains how to check and fine-tune them. This is crucial to the quality of the Locomotion Behavior output.

Are Animations of the same style ?

Make also sure that all animations in the locomotion set have the same style and can be correctly blended together as stated here.

Is the Locomotion Set correct ?

If using the locomotion still produce animation glitches, the problem might be a badly distributed locomotion set in terms of linear and angular speeds. To check this, it'll be needed to start the simulation and select a character to display the Visual Feedback Tool.

Look out for the Locomotion Behavior and check the Locomotion Database:

A correctly distributed locomotion database

Each of the dot in the visual feedback corresponds to one of the motions in the locomotion set, its coordinates being its angular and linear speeds.

The red dot is the desired linear and angular velocities (the control command), and the triangle in which it stands are the 3 motions that are currently blended together. When the navigation asks for different velocities, the control command will be changed accordingly, and so will the blended animation's weights.

Now when the database has very narrow triangles, it means that any slight change in the control command may bring a wide change in the blending parameters, or even change the currently blended motions ("switching between different motions"), so it's strongly advised to avoid narrow triangles in this database. When narrow triangles are identified, it's useful to also identify the motion files that produce them. This is done by putting the mouse on each point, which should bring a tooltip showing the name of the motion, as well as its angular and linear velocities:

Tooltip information for a motion in the database

Here are some examples of badly configured locomotion set:

Two animation have almost the same linear and angular velocities.
In that case, the two walk animation are different variations of the same animation. They should be configured as variations, check here.

An animation with a very little angular velocity was used together with it's mirror version. That produce a very narrow triangle and should not be done. Only animations with a high enough angular velocity should be used with their mirror version. Check the mirror configuration in the locomotion behavior documentation.

This locomotion set only uses animations that turns on left side but none turning on the right side. Check out this FAQ.